The team determined the root cause was related to index changes on a hot job queue table, leading to high CPU usage. The correct indexes were applied and the database returned to full health.
Posted May 13, 2026 - 22:55 UTC
Monitoring
The team has deployed a fix and the database load is now back to normal. We are monitoring for any further issues.
Posted May 13, 2026 - 17:48 UTC
Investigating
Platform is experiencing stability due to increased database load. The team is investigating and looking for mitigations.
Posted May 13, 2026 - 16:47 UTC
This incident affected: Grain Desktop App and Grain Web App.