Platform Instability

Incident Report for Grain

Resolved

The team has deployed a fix around large memory spikes trigging out-of-memory failures. Since the latest fix, no further memory spikes have occurred.
Posted Mar 27, 2026 - 21:02 UTC

Monitoring

The mitigation has prevented further instability but the team is still investigating the root cause of the issue. The issue caused intermittent and cascading excess memory pressure on the application nodes.
Posted Mar 24, 2026 - 17:08 UTC

Update

The team has rolled out mitigations and we're not longer seeing node failures. However we are still investigating the root cause of the issue.
Posted Mar 23, 2026 - 15:53 UTC

Investigating

The platform is currently experiencing instability, the team is deploying upgraded infrastructure and investigating the root cause.
Posted Mar 23, 2026 - 15:08 UTC
This incident affected: Grain Desktop App, Recording Processing, and Grain Web App.